Even though the current available REST endpoints are working as expected, we should revisit the naming pattern there to follow some common best practices (e.g. a good description can be found at http://www.vinaysahni.com/best-practices-for-a-pragmatic-restful-api , but there are more resources which basically suggest the same).
Currently, we do have something like this:
According to the documentation, better would be:
Having 5 or the invocation ID with 461... in the URL itself, you have to pass it to get some details and thus it's clearly not optional and easily readable.
, : I would like to hear your opinion on this as you have designed the current REST API. Do you see any problems with this approach?