CMR build fails with JDK 1.8

Description

Build fails with following error:

Possible reason:
While the tools.jar of JDK 1.7 contains the class com/sun/mirror/apt/AnnotationProcessorFactory, the tools.jar of JDK 1.8 does not contain that package at all.

Environment

Java 8

Activity

Show:
Ivan Senic
July 29, 2015, 8:30 AM

Basically we do restrict the build to work only on Java 7 (versions 51 to 80) due to the memory calculation tests. But we should dig into this and find a solution as users could be annoyed by fact that they can not make a release with Java 8.

Decreasing the priority.

Patrice Bouillet
August 7, 2015, 12:48 PM
Edited

I'll just go for the fix to make the build work in this case for jdk 8. The second part to restrict the building to only use jdk 1.7 is another thing.

Anonymous
September 6, 2015, 11:36 AM

Ditore

Assignee

Patrice Bouillet

Reporter

Alexander Wert

Labels

None

Integrator

Ivan Senic

Components

Sprint

None

Fix versions

Affects versions

Priority

Low
Configure